PDFreactor and the application server running the PDFreactor Web Service are Java based, so you need a supported Java VM. The PDFreactor installer (including Web Service) for Windows and macOS already contain a Java VM which will be installed exclusively for PDFreactor. If you are installing PDFreactor on UNIX/Linux you have to install a compatible Java VM suitable for your distribution.


Officially Recommended Java VM for the PDFreactor Library/Web Service:

  • OpenJDK 11

Other Java VMs Supported by the PDFreactor Library/Web Service:

  • Oracle JRE 8
  • Oracle JRE 7 (Library only)


The latest updates and service packs should be installed. We have customers successfully using the product in Oracle or IBM JVMs, but we don't officially test on those platforms.